自鯖の構成

右往左往しながら、最終的な構成は次のとおり。

パーツDeskMini X300DeskMini H470ThinkCentre M630e 改
CPUAMD Ryzen 3 PRO 4350G
(4コア/8スレッド)
INTEL Core i3-10100
(4コア/8スレッド)
INTEL Core i3-8145U
(2コア/4スレッド)
メモリ16GB x 2
(SILICON POWER
SP032GBSFU320F22
DDR4 PC4-25600)
16GB x 2
(CFD D4N2666PS-16G
DDR4 PC4-21300)
16GB x 1
(CFD D4N2666PS-16G
DDR4 PC4-21300)
ストレージ(OS用)Crucial P2
CT500P2SSD8JP
(M.2 MVNe 500GB)
Crucial MX500
CT500MX500SSD1JP
(SATA3 500GB)
WD Blue SN550
WDS500G2B0C-EC
(M.2 MVNe 500GB)
ストレージ(OSD用)Crucial MX500
CT1000MX500SSD1JP
(SATA3 1TB)
Crucial MX500
CT1000MX500SSD1JP
(SATA3 1TB)
WD Blue
WDS100T2B0A-EC
(SATA3 1TB)
その他外付け USB HDD 1TB
※バックアップ保存用

もともと H470 には OS 用も OSD 用も Western Digital の SSD を使ってた。
でも、OS 用の WD Blue SN500 は全く安定せず Proxmox のインストールもままならない状態だった。(たまたま上手く行くこともあった)
なので Crucial MX500 を OS 用にしてみたところ、エラーはめっきり減少した。

それでも毎日何かしらのエラーが出て Ceph が不健康になるから、その度 ceph pg repair x.x を実行してた。他と比較ができないから「こんなものかなぁ」と思いつつ、でも毎日こんな状態じゃ本格的な運用はとても無理だろうなということで、もう少し詳細原因を調べたのが昨日。
やっぱりというか、またかというか、OSD 用の WD Blue でも read error が出てた。
念の為、BIOS を最新版(2.10)にアップデートしても状況は変わらず。

それじゃぁということで、WD の SSD は M630e に、H470 には M.2 SSD を諦めて Crucial MX500 を使ってみたところ、問題の error はパッタリ無くなった。WD SSD になった M630e もあっさり Proxmox をインストール、起動できた。

結論として、DeskMini H470 に WD Blue の SSD はお勧めできないな。
Windows なら判らないけど。



おまけ。SATA のケーブル抜き差しを何度か繰り返したせいかもしれないが、syslog で kernel: ata4.00: status: { DRDY } というメッセージが出てたから調べたところ、ケーブルの不具合が考えられるらしいことが判った。念の為ケーブルを交換したところ無事、解消された。ata4 は OSD 用の SSD が接続されているインターフェース。

あとは、余った M630e で使用してた M.2 SSD 256GB を H470 の OS 用にするのも有りかな。

コメント

コメントする

目次
閉じる